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This guide describes an installation on Windows 7.

The installation under older Windows versions starting from 2000, as well as under newer Windows versions

takes place accordingly.

It is advisable to tick the box "Always trust software from HAEHNE GmbH".

The driver installation will now be completed in the background. Occasionally it may happen that you are asked to 

restart the computer. The HAEHNE GmbH driver package was derived from a driver package signed by Microsoft, 

whereby only a few character strings and the identification features of the CA-USB Sensor Interface..

Please note that Windows requires administrator rights to install drivers!  

Please check with your administrator if you do not have it!  

Log on to the PC as an administrator.

Before installation please close all programs and save all your data. 

In addition, all other applications should be closed, especially virus scanners.

Disconnect all HAEHNE devices from your PC.

Remove any existing HAEHNE USB Sensor Drivers. 

Control Panel> Programs / Software> Uninstall Programs 

Manual uninstall: Run> cmd.exe (as administrator)> pnputil.exe (driver management)

Be sure to pay attention!

Driver Installation
The necessary CA-USB device drivers are available as downloads on the HAEHNE homepage in the form of a 

ZIP file: https://haehne.de/en/service/download-device-software/

The necessary CA-USB device drivers are available as downloads on the HAEHNE homepage in the form of a 

ZIP file: https://haehne.de/service/download-geraete-software/

During the installation, please select the folder that matches your Windows version and run the 

 “HaehneVCPInstaller.exe” required for your operating system.

Digital Measuring Amplifier CA-USB
Installation Instructions for USB Drivers

Before Installation

http://www.haehne.de
https://haehne.de/en/service/download-device-software/
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Check Installation
The driver installation is completed in the background. There is no notification of success. Connect the USB device 

to the PC (you may have to confirm messages, depending on the operating system). 

The correct installation will be checked  
in Device Manager:

Open the Device Manager:

  -	 Start via Control Panel: 
	 System> Device Manager

  - 	Start with key combination: 
	 Windows key + pause> Device Manager

  - 	Manual start: 
	 Run> devmgmt.msc

CA-USB IA EN 08_19

Debugging

Error Possible Cause Correction

Amplifier listed under "?" or
"Other devices>
Unknown device / USB device ".

Driver not installed. 

Remove the amplifier from the PC. In-
stall driver package. The first installation 
must be done with administrator rights. 
Connect the device to the PC. Uninstall 
existing old drivers.

Driver installation aborts with errors.
Administrator rights are 
missing.

Repeat the process with administrator 
rights.

Driver installation on connection fails.
Administrator rights are  
missing.

Repeat the process with administrator 
rights.

If the entry "Haehne USB sensor interface Port (COM #)" appears, the driver package is installed correctly

(see picture).

Under this COM port, the device can be addressed by your software. If you connect several HAEHNE USB 

devices, a separate line appears in the Device Manager for each device.

https://www.haehne.de
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1 Remarks
This manual describes the installation under Windows 7. The installation under Windows 8 - 10 occurs ac-
cordingly.
Please note that Windows imperatively requires administrator rights for the installation of drivers.
Please speak to your administrator if you do not have those rights and be shure to pay attention to "CA-USB 
Installation Instruction".

License Terms for HAEHNE Software

The copyrights for this software remain at:

HAEHNE Elektronische Messgeräte GmbH
Heinrich-Hertz-Str. 29
40699 Erkrath 
https://haehne.com/

During the software installation, the license conditions will be displayed and must be accepted, otherwise the 
installation will be aborted. After the installation, the license conditions can be viewed in menu ‘Help > Advice’

Intended Use

The VS3-H software was designed for the adjustment, control and read-out of the CA-USB. Further functions 
of the VS3-H are reception, display and storing of measured values. Any use beyond this is considered as 
not intended.

System Reqiurements

The operation of VS3-H requires a PC with following system conditions:
	 • Windows 7 - 10 
	 • USB interface
	 • Maximal two monitors will be supported 

Recommended Hardware Requirements:
	 • Application process without diagram: Single-Core from 2,0 GHz
	 • Application process with diagram:      Dual-Core from 1,8 GHz
	 • The higher the sampling rate and the longer a measurement lasts, the higher the required main storage 
	  should be. The measurement ends as soon as the system does not provide anymore free main storage 
	  space. The absolute size of the main storage is depending on the operation system and the components 
	  installed in addition.

https://www.haehne.de
http://haehne.de


HAEHNE  Elektronische Messgeräte GmbH · Heinrich-Hertz-Str. 29 · D-40699 Erkrath Germany · Telefon 0211/9  25 91-0 · Fax 0211/9  25 91-20
http://www.haehne.de	 Email: info@haehne.de

- 5 -

2  Preamble
Product Description

This operation manual describes characteristics and operation courses of VS3-H. 

Setup of the Software

The VS3-H consists of following components:
	 • Configuration possibilities for the  VS3-H
	 • Storage of sensor-related scaling and adjustment data
	 • For the presentation of measured data (actual value, tare value, minimal and maximal value)
	 • Display and storage of measured data evaluations
	 • Presentation of the measured data in a diagram 
	 • Storage of measured data in CSV-format (output configurable)
	 • Storage of the diagram in BMP-format (output size configurable )
	 • Print-out of the diagram (output size defined)
	 • Presentation of the sensor information

Note

3  Starting the Software
The software only starts if it can find at least one compatible sensor. After starting the executable, the search for a 
compatible sensor appears. If the search is unsuccessful, please check whether the cables from the sensor to the 
PC are undamaged and that the corresponding drivers have been installed correctly. Please also check if another 
software is connected to the sensor and disconnect this connection if necessary. Please check also whether the 
USB plug has been inserted correctly. Then click on 'Search again' to search again for a compatible sensor. If a 
compatible sensor is found, the sensor-related data is automatically read out. If you only want to work with sen-
sors that are equipped with a USB interface, the search can be accelerated. To do this, click on the box "USB 
only". This setting can be changed at any time (here and in the dialog "Sensor connection").

- Observe the correct sensor adjustment.
- Consider the correct VS3-H configuration. 
- Choose a significant file identification/prefix when storing measured data..
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4 Description of the Operating Mode
The software consists of a menu bar, navigation bar, status bar and a workspace. The functions of the menu bar 
comply with the navigation bar. The digital measured values of the physical values, the valuation display and the 
diagram can be seen in ‘Operating Mode > Meas./Diagram Mode’. In the workspace the consolidated dialogs are 
displayed in ‘Operating Mode’.
	 • Adjust. Mode (.2)
	 • Meas./Diagram Mode (4.3)
Switching between the dialog boxes can be done through the navigation bar as well as via the equivalent menu 
bar. Adjustment changes in the dialog box will be accepted without confirmation. All settings will be saved when 
the application is closed and reloaded when the application is restarted. The status bar displays current status 
information of the application
	 •‘Ready for use. Sensor connected’
	 •‘Sensor disconnected’
	 •‘Measure...’
	 •‘wait for trigger start event’
	 •‘Measure! Wait for trigger stop event’
Furthermore, information from the menu bar and navigation bar  
through the control elements as well as the storage progress  
in a CSV-file are indicated in the status bar.

* Measurement: recording of a measured value series in the configured measuring rate of Start […] to Stop […].

Attention!

All output adjustments must be carried out be-
fore the measurement.

4.1. The Menu Bar/Navigation Bar of the Program 

4.1.1 File > Save Measured Value (Shortcut ‚Ctrl+M’)

From here, the measured data of the last measurement  are stored in  
a CSV-file. The output format of the file is adjustable in dialog box  
‘Operating Mode > Adjust. Mode > Documentation’ under the headline 
 ‘Output measured values’ (4.2.4. Documentation > Output  
Measured Values) 
In the first column of the CSV-file, the measured values are numbered 
ascending.  The output of columns two to maximal three will be taken 
over by adjustment ‘Operating Mode > Adjust. Mode > Measure Adjust.’ 
under the ‘Diagram’ headline.  Here, each adjusted physical value will 
be written into the file. 
The sequence: [X-Axis], [Y1- Axis], [Y2- Axis].

https://www.haehne.de
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The diagram has a context menu. By right-click on the mouse key, following functions are available:

	 • Zoom in:	 The mouse pointer becomes cross-shaped. By pressing the left mouse key and moving the  
			   mouse in the diagram, a rectangle appears which can be zoomed by releasing the mouse key.
	 • Zoom out:	 The diagram indicates the complete range of the previous measurement.  

<  Range slider

<  Interval slider

Note

A CSV-file is a text file for the storage of simply structured data.  The abbreviation CSV stands for  ‘Char-
acter Separated Values’ or  ‘Comma Separated Values’. These values are separated from each other by 
special delimiters, e.g. by a comma or a semicolon. A CSV-file can be started by Excel® through double-
click (Windows Excel® 2007 - import via data > “from text”). 
 
The denotation of list/field/line-ending marks is not explicitly determined. The definitions under  
4.2.4. Documentation > Output Measured Values > ‘End of line character’ / ’Column separator’ / ’Deci-
mal separator’ must possibly be adjusted in VS3-H or in your spreadsheet. 

4.1.2  File > Save Diagram (Shortcut ‘Ctrl+D’)
From here, measured data of the previous measurement can be stored in a BMP-file.
Predefined output variables can be adjusted in ‘Operating Mode > Adjust. Mode > Documentation’ under the 
‘Output diagram’ heading in box ‘Memory size’. There are following possibilities: 

	 • max:	 Adjustment is only available, if the running system recognizes two monitors.  
			   On these two monitors, the diagram is maximum size stretched and stored. 
	 • normal:	 The diagram is stretched to approx. screen size and stored.
	 • min:	 The diagram is stretched to approx. 800x600 pixel of the monitor and stored.
	 • Window:	 The diagram gets stored the way it was adjusted by the user. Any measurement range can  
			   be selected by the range slider and the interval slider. 
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	 • Scrolling: 	 The mouse pointer becomes cross-shaped with arrows. By holding the left mouse key in the  
			   diagram, the curve can be shifted.
	 • Grid on/off:	 The dashed lines in the diagram form the grid.  By this function, the dashed lines can be  
			   faded in/out. 
	 • Show legend:	The legend indicates the physical variables and their units. By this function, it can  
			   be faded in/out. 

4.1.3 File > Print (Shortcut ‘Ctrl+P’)
This function enables the print-out of the diagram with print time, con-
figurable heading, configurable remark, configurable address as well 
as a customized  Logo (picture to the right).
The user can carry out the configuration by the navigation bar  
“documentation”.   
Line breaks in remark and address are converted into blanks.
Following restrictions are valid
	 • The heading is restricted to 20 characters
	 • The remark is restricted to 57 characters
	 • The address is restricted to 82 characters 

4.1.4 File > Exit (Shortcut ‘Ctrl+E’)
Closes the program. If the program is still in the measuring mode while closing, the measurement will be ended.  
If automatic storage is adjusted it will be executed before the program is closed.
(4.2.4. Documentation > Output Measured Values and > Output Diagram)

4.1.5 Operating Mode
This umbrella term contains all sensor-specific adjustments ‘Adjust. Mode’ as well as the ‘Meas./Diagram Mode’. 
By selecting a mode it will be displayed in the workspace. Following dialog boxes can be displayed:
	 • Adjust. Mode > Sensor Connection (4.2.1)
	 • Adjust. Mode > Sensor Information (4.2.2)
	 • Adjust. Mode > Measure Adjust. (4.2.3)
	 • Adjust. Mode > Documentation (4.2.4)
	 • Adjust. Mode > Sensor Adjustment (4.2.5)
	 • Meas./Diagram Mode  (4.3)
When restarting the software it will start with the previous active dialog box. The next menu can be entered  
via the shortcut ‘Ctrl+TAB’; the previous menu can be entered by ‘Ctrl+Shift+TAB’

Attention!

When storing the diagram, only the currently presented 
part of the measurement will be stored. 
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4.1.6 View
The control elements under ‘View’ are responsible for fade in/out of bars and displays as well as setting back 
the windows view. In the menu/navigation bar a checkmark indicates faded in/out bars and displays. The digital 
displays and the diagram can only be switched in the measuring and diagram mode, otherwise they are grey 
(disabled). While executing ‘View > Reset Views’ (e. g. via the shortcut ‘Ctrl+R’) the digital displays, the diagram 
and the main window are set back to original condition.

4.1.7 Language
Here, the language of the VS3-H can be adjusted. 
All indications of the application are changed in accordance with the selected language. 
Following languages are supported:
	 • German
	 • English
	 • French
At restart of the software, the previously adjusted language will show.

4.1.8 Help > Info

Here, the version number of the software is indicated.

4.1.9 Help > Advice
Contains the license conditions for this software, the ad-
dress as well as the website and e-mail links. 
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4.2 Configuration Mode
The configuration mode contains all of the sensor-, measurement- and documentation adjustments as well as the 
output of sensor information. The adjustment dialog boxes are presented in the work space through the menu/
navigation bar. In the following chapters, the adjustments are introduced and the functions are explained. 

4.2.1 Sensor Connection

This software only supports HAEHNE devices of the type CA-USB. If only one HAEHNE device is directly or 
indirectly connected to the PC, this is automatically activated by the VS3-H. The VS3-H can only activate one 
device at a time. In the case of several devices, the one that was active in the previous application session 
is activated. With a simple double-click on one of the displayed lines, with the status 'available', the desired 
device is activated. Devices and sensors marked 'not available' in the 'Status' column can not be activated. 

'Not available' means that the VS3-H can not open or activate the interface, or that the device has not 
responded. If another process or another application accesses the desired interface, this access must be 
terminated and the "Refresh" button must be searched for free interfaces again. 
The status 'not supported' indicates devices not supported by the VS3-H software with HAEHNE protocol-
enabled sensors.

The list provides further information about the device, such as baud rate (115.2 or 230.4 kBaud), address, 
serial number, full scale value and sensor type and the actual nominal value of the channel at or the interface 
type DMS.

Disabling a device is done either by activating another device or by double-clicking on the active device. 
Disabling releases the COM interface and can be used by other applications.
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Device Connection - Baud Rate

Device Connection > Update
During this update all HAEHNE interfaces which are integrated in the PC will be checked and read-out. The baud 
rate and the device address are determined and set automatically. Furthermore the complete sensor data and 
sensor information will be read-out. The progress of the update will be visually presented (see following image). 
The update is also started every time a device is disconnected or connected via a USB port.

Baud Rate Maximal adjustable measure rate

115200 Baud 2500 Meas./s
230400 Baud 5000 Meas./s

Note

•	 The changed baud rate is constantly stored in the sensor. This 
adjustment is also valid for the interplay with other applications. 

•	 The maximal adjustable sampling rate is depending on the adjust-
ed baud rate and the used processor of the PC.

The baud rate can be switched to the corresponding interface between 115.2 kBaud and 230.4 kBaud with the 
click of a button in the baud rate column (see example, Interface '"HAEHNE USB [COM 8]")
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4.2.2 Sensor Information

The dialogs shown above display information and properties about the activated sensor. The data is read by the 
VS3-H when the sensor is activated. If no sensor is activated, all information is displayed 'n. a.'. If the measure-
ment uncertainty is equal to 'n. a.', this means that there is no measurement uncertainty for the activated sensor. 
This value in% can be determined with a factory calibration or with a DKD calibration. The determined value can 
be stored in the 'Sensor adjustment' menu under 'Store measurement uncertainty in sensor' in the activated sen-
sor.
The VS3-H compatible Amplifiers each have two memory locations for adjustment values, a fixed factory adjust-
ment block, and a variable user adjustment block. The status 'active' during the user adjustment is additionally 
marked with a '*' if this adjustment uses the same factors as the factory adjustment. This is the case after the 
subsequent storage of a measurement uncertainty during active factory adjustment.

Sensor Information > Common
In addition to the invariable factory parameters such as sensor type, ID, revision and factory calibration, informa-
tion about the activated device is also stored here.
Under the heading "Sensor" you will find in brackets the name of the device with the sensor type.

Sensor Information > Channel
These fields contain information about the measuring channel. The serial number of the CA-USB is preset. The 
serial number of the channel can be changed by the user, if eg. B. the serial number of the connected sensor 
should be stored. Possible characters are uppercase and lowercase letters from A to Z and numbers from 0 to 9.
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4.2.3 Measurement Adjustment

In this dialog box all measuring adjustments can be viewed and changed. The measurement adjustments are 
subdivided into measured variable, diagram, trigger and OK/NOK - evaluation. Except for the serial number, 
these adjustments will be accepted without confirmation. 
The adjustments in  
Measured variable > Type, Measured variable > Sampling rate, Measured variable > Display and 
Measured variable > Diagram > Reducing the sampling rate by averaging via X values   
are sensor related data and are saved in the sensor. Herewith an automatic configuration of the software to the 
connected sensor is warranted.
When the application is finished, the previously not mentioned values are stored in the Windows registry under 
the logged in user and restored after a restart of the software. 
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Measure Adjust. > Measured Variable > Low Pass Filter

The integrated analog input filter is configured with this setting. 
The following 3 dBc frequencies are adjustable: 30 Hz, 300 Hz, 1000 Hz, 3000 Hz.

Measure Adjust. > Measured Value > Sampling Rate

Following measuring/sampling rates are adjustable: 5000/sec, 2500/sec, 1250/sec, 1000/sec, 500/sec, 250/sec, 
200/sec, 185/sec, 100/sec, 50/sec, 33/sec, 25/sec, 20/sec, 10/sec, 1/sec, 50/min, 20/min, 10/min, 1/min.
The maximal adjustable sampling rate is depending on the adjusted baud rate and the PC system 
(4.2.1. Sensor Connection-Baud Rate). 

Measured Adjust. > Measured Variable > Display

The connected CA-USB will b displayed as channel 1.

The adjustments under ‘Measured variable > Display’ determine the output and display of the respective chan-
nel. Hereby, the number of decimal places, the unit, gliding averaging and the leading sign can be selected and 
configured. 
Up to four decimal places can be indicated for every physical size. This adjustment is considered in the digital dis-
plays, in the diagram and in the readout of the CSV-file.  For the adjustment of the unit of a physical size, German, 
English and American units can be selected.  
The conversion onto the adjusted unit is automatically carried out by the software. The under “Scaling” addition-
ally defined unit is shown in square brackets. A gliding average can be formed for each physical size of 1 to 512 
values, with a grading in raster 2n of the adjusted sampling rate. The leading sign of the channel is predefined in 
the sensor and can be changed through the adjustment ‘Measured variable > Display > Sign’*.

Key ‘Change’  under Scaling opens a dialog which allows scaling as well as the definition of an additional unit.  In 
the choice box ‘Measured variable > Display > Unit‘, the additional unit is marked with square brackets.

Note
*  If no scaling was stored, ‘Create’ will appear instead of ‘Change’ and the selection in the unit  
	 box is limited to the device type without an additional unit.
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In dialog ‘Scaling Change’ the input variable (see image 
‘Scaling Change’) can be scaled with an arbitrary unit. The 
‘Sensor adjustment’ displays the defined proprietary calibra-
tion and/or the user adjustment of the channel. In the figure, 
channel A is selected with the input quantity DMS which 
outputs the nominal value 10000 ADU at 1000 mV / V.
With the help of the input fields in the box Scaling a  
rescaling of these values can be performed.

In the left input box either a certain force value can be entered or the actual measured value of the sensor can be 
read. In the middle input field, enter the new output value that corresponds to the input value from the left field. In 
the right input box a unit with a maximum length of 5 digits can be entered. By pressing key Change, these inputs 
will be saved in the sensor. The application sets the newly defined under, Measure> Representation> Unit '.

Measure Adjust. > Diagram

In input box ‘Reducing the sampling rate by averaging via X values’ it is possible to decrease the measuring 
points which should be saved by entering a value for X. Hence, the adjusted sampling rate e.g. 200/sec at X=10 
will be reduced to 20 displayed values in the diagram. This is also valid for storing the measured values in a file. 
When reducing the sampling rate, an averaging over the last X values is carried out.

Note
The closer the scaling value to the final value of the sensor, the more  
precisely is the display of the measured value during the measurement.

When setting this configuration, the X axis should be started. As a result of setting the X-axis, the application 
updates the number of Y-axes and their selectable content.
All combinations of the measured quantities can be shown in the diagram.

Note
•	 The adjustment ‘Reducing the sampling rate by averaging via X values.’ has no effect on the represent-

ed values in the digital displays.
•	 The adjustments under 4.2.3 Measure Adjust. > Measured variable > Display > Average of the indi-

vidual physical sizes and the adjustment ‘Reducing the sampling rate by averaging via X values.’ act 
cumulatively.

•	 When the diagram is updated during a running measurement, the complete measurement is displayed 
at a resulting measurement rate less than or equal to 20 measurements per second. At measurement 
rates above 20 measurements per second, only the last minute of the measurement is displayed. After 
completing a measurement, the complete measurement is always displayed in the diagram.

Attention!
The measured values are written to the CSV file. The order of writing is: [X-axis], [Y1-axis], [Y2-axis]. It is 
also possible to set Y-axis to 'Off' if it is not needed. However, the application takes care that at least one 
size on the Y-axis is not off.
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Measure Adjust. > Trigger

	 Course:
	 1. Select a start event.
	 2. Select a stop event.
	 3. Enter Trigger key.
	 4. Actuate a trigger start event.
	 5. Actuate a trigger stop event.
	 6. Measurement recorded.
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In the previous signal flowchart, the general course of measurement by means of a triggering is described. The 
activation button ‘Trigger’ can be found in the ‘Meas./Diagram Mode’ under ‘Measure Stop’. The software trig-
gering consists of two events which are adjustable according the requirements as follows:

	 • Trigger Start > Source:
	 -	 Off/Measure Start:
		  Entering ‘Measure Start’ releases the Trigger start event. (The function to start an event can also be  
		  entered in the following sources). 
	 -	 Channel A:
		  4.2.3. Trigger
	 -	 System time:
		  The application shows an input box where the date and the time of the measurement start can be adjusted.  
		  The adjustment is limited to the current time plus 15 seconds. These values must be re-adjusted after each  
		  measurement; otherwise the following measurement will start immediately by pressing the trigger, because  
		  the previously adjusted time lies in the past

	 • Trigger Stop > Source:
	 -	 Off/Measure Stop:
		  Entering ‘Measure Stop’ releases the Trigger stop event. (The function to stop an event can also be  
		  entered in the following sources)
	 -	 Channel A:
		  4.2.3. Trigger
	 -	 Measurement Duration:
		  For this selection an input box is available. The time unit (seconds, minutes) is taken from the sampling rate.  
		  The number of measurements is calculated and displayed by the application next to the input box. 
	 -	 Number of Measurements:
		  For this selection, an input box is available to indicate the number of measuring points. The measurement  
		  duration is displayed and calculated next to the input box. The time unit (seconds, minutes) is taken from  
		  the sampling rate.

Note
The source adjustments of trigger start and trigger stop can be optionally combined with each other.
The adjustments “Measurement duration” and “Number of measurements” refer to the adjusted sampling 
rate and not to the reduction of the sampling rate.

After Executing Start/Stop: 

Two trigger events can be assigned actions through these fields. After the event occurrence and/or evaluation  
and storage actions, the program specified in this field will be executed.  
Any executable files and batch files are admissible. These files can be manually specified with full path or  
selected via requester through the folder icon.
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Trigger

The picture on the following page shows an  
example of how a measurement by means of  
triggering can be recorded to a physical variable. 
At excess, the hysteresis value will be deducted  
from the threshold and at under-run it will be  
added. 

At this triggering not only the value of threshold (Yover; Zover) of a physical variable, but also a direction must be 
indicated. In the example diagram, the direction ‘over run’ is triggered. This means that the measured value must 
drop below the hysteresis value first, before the trigger is responsive to the exceeding of the threshold. In contrast, 
the setting “drop below” means that the measured value must rise over the hysteresis value before the trigger is 
responsive to dropping below the threshold value.
The grey boxed area of the example diagram corresponds to the display in the diagram of the VS3 after the mea-
surement. This area can be saved in a CSV-file. 
•	 Yover = Trigger start value of a physical variable with directional adjustment ‘over run’
•	 Zover = Trigger stop value of a physical variable with directional adjustment ‘under run 

Example Diagram

Hysteresis

The size of the hysteresis is 1% of the specified maximum input value.   

Measurement Adjustments > OK/NOK Evaluation

These settings affect the evaluation of a measurement series. After a trigger stop  
event occurs, the max. values of these measurement series are determined and  
compared with the stored limits. In order to obtain an OK-display, the max. value  
of a measurement series must be above the lower and below the upper limit. 
If two conditions are defined, both conditions must meet the OK criteria for a  
total OK-display.

Y over

Zover

Trigger start  
event

Trigger stop  
event

channel A
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4.2.4 Documentation

Here, the user can carry out documentation configuration. The adjustments refer to the storage of measurements 
as BMP and/or CSV-file.

Documentation > Output Measured Values

•	 Automatic Storage:
	 The storage of the measured value into an output file can occur automatically by the software.  
	 Three adjustment possibilities can be selected:
	 - 	 None: The automatic storage is disabled.
	 - 	 Save all measurements into one file: This option files each measurement in the same CSV-file at the end. 
		  The name from the prefix field is used as the file name. The file is saved in the registered target directory.
	 -	 Save each measurement with its own index: This option creates a separate CSV-file at the end of each  
		  measurement. The file name consists of the prefix and the index YYYYMMDDHHmmss####  
		  (‘####’ number beginning with leading zeros 0000; 0001; ...)
	 -	 The path length is limited by the operating system.

Note
Definition „Measurement“ (4.1.1)  
File > Save Measured Value (Shortcut ‚Strg+M’)
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•	 Target Directory:
	 The target path is entered in ‘Target directory’ (Standard adjustment  ...\ 
	 <user name>\My documents\VS3-H).  
	 Likewise you can click on the folder and select a directory.
•	 Prefix:
	 Please enter the file name which is used for the automatic storage in this  
	 input box. (Further details about file name/prefix can be found under  
	 headline “Automatic Storage”. 

Documentation > Output Diagram

•	 Automatic Storage:
	 The software can automatically save the diagram in an output file. For this, three adjustment possibilities  
	 are available:
	 -	 None: the automatic storage is disabled.
	 -	 Write all measurements to a file: This option attaches every further measurement to the same CSV file 
		   at the end. The name from the Prefix field is used as the file name. The file is saved in the entered  
		  destination directory.	
	 -	 Save any diagram with an own index:  this option creates a separate BMP-file at the end of each  
		  measurement. The file name is a combination of the prefix and the index YYYYMMTTHHmmss####  
		  (‘####’ number beginning with leading zeros 0000; 0001; …). 	
		  The path length is limited by the running system.

•	 Target Directory:
	 The target path is registered in ‘Target directory’ (standard adjustment  ...\ 
	 <user name>\my documents\VS3-H). Instead of this, you can click on the  
	 folder and select a directory.
•	 Prefix:
	 Enter the file name which shall be used for the automatic storage in this  
	 input box (further details regarding file name/prefix can be found under the  
	 headline ‘Automatic Storage’).

Common Settings Output Values and Output OK/NOK-Evaluation

•	 End of line character:
	 The desired line ending mark for the output in a file gets adjusted in this box.
	 Following possibilities can be selected:
	 CRLF:	 Carriage Return / Line Feed	 Carriage return line feed (MS-DOS, Windows)
	 LFCR:	 Line Feed / Carriage Return	 Line feed carriage return  (Linux Konsole)
	 CR:		  Carriage Return	 Carriage return  (Apple II, Apple Mac OS up to Version 9)
	 LF:		  Line Feed	 Line feed (Unix-Derivate, Mac OS X)
•	 Column separator:
	 The column delimiter will be read out at the first execution of the application from Windows system control  
	 (country selection) and will be set accordingly.
	 At each further restart of the application, the previously adjusted delimiter will be used.  
	 Following selection is possible in this box: 
	 TAB :	 Tabulator
	 ;  :		  Semicolon
	 ,  :		  Comma
	 .  :		  Point
	 Space : 	Space character
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•	 Decimal Separator:
	 The decimal delimiter is carried out the same way as described for the column separator.  
	 Following selection is possible in this box:
	 , :	 Comma
	 . :	 Point

 

•	 Additional Information Show / Hide:
	 In this group, checkmarks can be placed to add further information to the output of measured values.  
	 The entries in the three entry boxes ‘Headline’, ‘Address’ and ‘Comment’ can be specified arbitrarily.  
	 With the checkmark, these entries will be recorded in the output file. The ‘Uncertainty of measurement’ -  
	 if the connected sensor has one - can also be displayed in the output file. By a checkmark in ‘Date / Time’  
	 the measurement period can also be recorded in the output file. By a checkmark in ‘Physical unit’ it is also  
	 possible to systematically fade in/out the physical units in the output file.

Documentation > Additional Information
This is free text which can be activated in ‘Documentation > Output Measured Values > Additional Information 
show / hide.

4.2.5 Sensor Adjustment

Here you can do three actions with the sensors:
Storage of the measurement uncertainty, adjustment and deletion of the user adjustment.
After deleting, the factory adjustment becomes current.

Note
Supplementary changes of the country adjustments in the oper-
ating system have no influence on the once adjusted values of 
this software.
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Store Uncertainty of Measurement in the Sensor

In this dialog, a measurement uncertainty in % (for example with regard to nominal value or adjustment value) can 
be stored in the connected sensor. This size, if present, will be displayed in the Sensor Information dialog. Fur-
thermore, the measurement uncertainty can be output in the CSV output file
(4.2.4. Documentation> Output Measured Values).
The value of the measurement uncertainty is usually determined during a factory or DKD calibration. If the fac-
tory calibration of the connected sensor is active and a value for the measurement uncertainty is given, then the 
sensor was subjected to factory or DKD calibration by HAEHNE GmbH. Permissible values of this size are [5%> 
Uncertainty> 0%]. The value of the measurement uncertainty is only for documentation. This value has no influ-
ence on the measured values.

Adjustment

In the factory setting, the following assignment is preset: ± 3,000 mV / V corresponds to ± 30000 digits,
or ± 1,000 mV / V correspond to ± 10,000 digits, etc.
In the "Adjustment" dialog, the CA-USB can be readjusted to the characteristic values according to the sensor as-
signed to it. The results are then stored in the device.

In this window the new adjustment values for 
the rated load (s) and ADU value (in the range 
between 5000 and 30000) are entered.
Pressing the button triggers the adjustment.
After the completion of this process, the adjust-
ment is completed.

Attention!
HAEHNE does not warrant or guarantee the user adjustment.
A corresponding warning is issued!

In the next step, the sensor is loaded or unloaded.
Pressing the 'NEXT' button triggers the adjustment for the determination of the zero point.
At the end of this process, the next dialogue of the sensor adjustment will appear.

In this dialog box "Channel A:
Perform the adjustment without
built-in control ".
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4.3 Meas./ Diagram Mode

In 'Meas./Diagram mode' the digital displays of the physical variables and the diagram can be activated. Only the 
indicators that are ticked under 'Measurement Adjust.> Measured variable> Type' are activated.

Each, the digital displays and the diagram are in a separate window These windows can be docked on  the main 
window or they can freely be placed on the monitor. In order to scroll the windows, the mouse pointer must be 
placed on the title bar of the respective window. By keeping the left mouse key pressed, the window can be 
moved or docked. The contents of the window automatically adjusts to the size of the  window. Pressing the ‘Ctrl’ 
key prevents docking with the main window.
Due to system-relevant restrictions under operating systems Windows 2000 and Windows XP it is not possible to 
draw the diagram out of the main window of the application. Also, with these operating systems, the application 
cannot be placed outside of the monitor. When trying, it will always go back to the visible workspace. 
Each digital display has four output fields, one for the current measured value, the tare value, the minimum value 
and the maximum value. The minimum and maximum value can be reset by the buttons ‘MIN Reset’ and ‘MAX 
Reset’. If the tare-button shows ’TARE’ and is kept pressed, this will set the current measured value to zero and 
the tare difference will be displayed above in the output field. Afterwards this button shows ‘TARA=0’, the taring 
can be canceled again.
The OK/NOK display always shows the total of all defined criteria. If the criteria is met, a green indicator appears. 
If at least one criterion is not met, the indicator turns red. A grey indicator means that there is currently no evalua-
tion, e.g. after start-up or after a new series of measurements was started.

Attention!
During a measurement the data connection to the  
PC is allowed not be interrupted!
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Measure Start:

With this button, a measurement gets started. 
The digital displays and the diagram will be fed with measured values after pressing this button. Unnecessary 
keys are deactivated during the measurement. Also, the status of the application “Measuring…” is indicated  
in the status bar. 
	 >	 Software Trigger start event

Measure Stop:

Can only be used during active measurement. As soon as the key was pressed, the measurement will be stopped 
and will initiate possible automatic storage (4.2.4 Documentation). At active automatic storage into a file, the 
progress is shown on the status bar as well as the idle state ‘Ready for use. Sensor connected’.
	 >	 Software Trigger stop event

Trigger:

This key activates a software triggering (4.2.3. Trigger). The status lamp on the side of the key blinks yellow at 
active triggering. By pressing again, the triggering will be deactivated. 

Trigger Auto Repeat:

If a tick is set, the trigger is reactivated as soon as all actions of the trigger stop event occur are processed  
for example: Write file.

Single Measurement:

With this key, a single current measured value gets requested from the active sensor. This function can only be 
carried out in the idle mode/measuring stop of the application.

Control:

The button ‘Control’ is only activated during the measurement at low sampling rates (<20/sec) and in idle mode. 
With the help of Control, the measuring bridge in the sensor gets detuned and issues the nominal range. A red 
lamp next to the button indicates active control. By clicking on ‘Control’ again, it will be deactivated.
This function is no longer supported by HAEHNE sensors.

Trigger LED Condition
Grey Trigger OFF

Yellow flashing Trigger waits for a trigger start event. Only 
the digital displays are updated

Green Trigger Measurement ON. Digital displays 
and diagram are updated with values. 

Note
Activate only, if Auto Storage is active (4.2.4.) .
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Measuring Time / Sampling Rate:

The maximum measuring time depends on the samplig rate set in the menu Measurement Adjust 
Measurement Adjust.  > Measured variable > Sampling rate (4.2.3)
After selecting a measurement duration, the measurement will be executed until the set time value has been rea-
ched after pressing "Measure Start". Once the measurement has been completed, a new measurement must be 
confirmed again with "Measure Start".
A measurement can be prematurely ended at any time with "Measure Stop".

Adjusted  
Sampling Rate 

Maximal 
Meas. time

Alternatively  
selectable measuring times

5000 Meas./s 4 min 1min / 2 min

2500 Meas./s 8 min 1min / 2 min / 4 min

1250 Meas./s 16 min 1min / 2 min / 4 min / 8 min

1000 Meas./s 32 min 2 min / 4 min / 8 min / 16 min

500 Meas./s 1 h 4 min / 8 min / 16 min / 32 min

250 Meas./s 2 h 8 min / 16 min / 32 min / 1 h

200 Meas./s 2 h
10 min / 20 min / 40 min / 1 h

185 Meas./s 2 h

100 Meas./s 5 h 20 min / 40 min / 1 h / 2 h

50 Meas./s 10 h 40 min / 1 h / 2 h / 5 h

33 Meas./s 16 h

1 h / 2 h / 4 h / 8 h25 Meas./s 16 h

20 Meas./s 16 h

10 Meas./s 2 d 3 h / 6 h / 12 h / 1 d

1 Meas./s 16 d
1 d / 2 d / 4 d / 8 d

50 Meas./min 16 d

20 Meas./min 64 d 4 d / 8 d / 16 d / 32 d

10 Meas./min 128 d 8 d / 16 d / 32 d / 64 d

1 Meas./min 480 d 30 d / 60 d / 120 d / 240 d
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5 Debugging
This chart helps to find frequent errors and the measures for debugging. 

Error Possible Cause Debugging

Application does not start The operating system is WIN98  
or older

Required operating system  
WIN XP / Vista / 7 - 10

No driver for USB sensors Follow the instructions for installing 
drivers for USB devices.

Sensor is not connected to the PC Connect the CA-USB to the PC
Sensor is connected to the PC but 
the application won’t start or com-
munication not available. 

Driver problems or errors in the 
connection line

Close the application and unplug 
the connection cable between the 
sensor and the PC




